Statistics on pomotv

Number of watchers on Github 189
Number of open issues 12
Average time to close an issue 11 days
Main language Ruby
Average time to merge a PR about 14 hours
Open pull requests 3+
Closed pull requests 6+
Last commit about 1 year ago
Repo Created about 3 years ago
Repo Last Updated 11 months ago
Size 35.8 MB
Homepage http://www.pomo.tv
Organization / Authorchriseidhof
Contributors20
Page Updated
Do you use pomotv? Leave a review!
View open issues (12)
View pomotv activity
View on github
Fresh, new opensource launches 🚀🚀🚀
Trendy new open source projects in your inbox! View examples

Subscribe to our mailing list

Evaluating pomotv for your project? Score Explanation
Commits Score (?)
Issues & PR Score (?)

iOS/Mac/Swift related videos indexed Build Status

See the rendered site: http://www.pomo.tv

To run this:

bundle install
bundle exec middleman

PR's encouraged.

To add videos for an event:

  • Add the videos to data/videos.yml. Also look at data/events.yml, data/editions.yml and data/speakers.yml and add the missing information there. It's important that we keep data/editions.yml sorted by date. Please take the time to add tags, this really helps for discovering new videos. Also, if there's a transcript/background-info/conference page for this video available, use the direct-link attribute to link to it.

You might also want to run bundle exec rake lint:speakers to verify that every speaker has a bio. Run bundle exec rake lint:editions to verify that every event has the correct info. You can check everything with bundle exec middleman build --clean. This automatically gets run if you make a PR.

If you want to import an entire YouTube account, you can run bundle exec rake fetchyt[uikonf] (replace uikonf with the name of the YouTube account). To do this, you need to create a .env file with a YouTube API account in there. You will need to edit the generated YAML before copy-pasting it into videos.yml.

Troubleshooting

If you get the following error:

An error occurred while installing eventmachine (1.0.8), and Bundler cannot
continue.
Make sure that `gem install eventmachine -v '1.0.8'` succeeds before bundling.

please perform the following command:

$ gem install eventmachine -v '1.0.8' -- --with-cppflags=-I/usr/local/opt/openssl/include
pomotv open issues Ask a question     (View All Issues)
  • over 2 years Build is broken
  • over 2 years Video ID generation struggles with some characters
  • over 2 years License
  • almost 3 years Add Seattle Xcoders videos
  • almost 3 years Recently added list, isn't
  • about 3 years Create events pages
  • about 3 years Optimize page speed
  • about 3 years ios-conf-videos
  • about 3 years Create a tvOS/iOS/etc app?
  • about 3 years Add slides to videos
  • about 3 years Add an API
  • about 3 years Add "Featured" section or discovery thing
pomotv open pull requests (View All Pulls)
  • mobile warsaw meetup videos
  • Added five more Swift Summit SF videos
  • Add NSLondon February and March 2016
pomotv list of languages used
Other projects in Ruby