Issues filed for ocaml/opam

View Full Project
Do you use opam? Leave a review!

Rate of open issues in the last 60 days

opam open issues (View Closed Issues)
  • almost 2 years OPAM 2.0 & variable OPAMKEEPBUILDDIR
  • almost 2 years Typo in Opam FAQ: correct: "opam-depext" wrong: "opam depext"
  • almost 2 years Broken link and github tag for 4.04.0
  • almost 2 years gpgsign=true in .gitconfig is breaking opam repo add
  • almost 2 years gsl incompatible with camlp4
  • almost 2 years building opam from source on Alpine Linux
  • almost 2 years on freebsd: set owner/group (was: 1001/0): Operation not perimtted
  • almost 2 years Reproducible builds
  • almost 2 years "Sorry, no solution found: (...)", but no further information from OPAM
  • almost 2 years [Documentation][2.0] Need more info about adding new compiler
  • almost 2 years opam behavior when disk is full
  • almost 2 years Error: Port opam not found
  • almost 2 years Should /usr/local should be included in the compiler CFLAGS on osx?
  • almost 2 years Could not update repository `default` for opam 2.0~beta
  • almost 2 years opam silently drops all dependencies when an undefined variable is encountered
  • almost 2 years Document opam-lib use-cases before OPAM2
  • almost 2 years maintainer information
  • almost 2 years Overly enthusiastic conflict message
  • almost 2 years OPAM does not compile with recent version of OCaml
  • about 2 years OpamStd dependency-free opam file format parser
  • about 2 years add a `compiler-bundle:` field
  • about 2 years Add hooks for validation of repository updates
  • about 2 years opam or OPAM ?
  • about 2 years Unix.lockf may fail on some platforms (e.g. Hurd)
  • about 2 years Options to navigate versions of a package.
  • about 2 years `~/.gitconfig` configuration option breaking opam git backend
  • about 2 years Feature: rename opam switches
  • about 2 years documentation clarification plus feature request for testing local opam-repository changes
  • over 2 years Replace absolute path of OPAMROOT in config files by a variable
  • over 2 years Tracking wishlist issue for opam 2.0
  • over 2 years Way to silence [WARNING] Running as root is not recommended ?
  • over 2 years create_process error on msys2
  • over 2 years opam wants to install github&cohttp whatever the operation requested
  • over 2 years '[ERROR] Too many downloaded files' when trying to install/init OPAM
  • over 2 years opam FAQ, macports, and virtualenv competing for environment variables.
  • over 2 years "opam switch list" should use a better ordering
  • over 2 years "opam update foo" is unreasonably slow
  • over 2 years [improvement/feature] Local opam configuration in the current directory
  • over 2 years Next: ocaml-version not updated with ocaml's version
  • over 2 years Next: `opam list --rec --required-by ` is a bit confusing
  • over 2 years Next: investigate gringo/aspcud performances
  • over 2 years Next, Feature request: `opam switch pin`
  • over 2 years Next: opam compiler-conf doesn't work anymore
  • over 2 years Bad error message for "opam pin add"
  • over 2 years Absence of a system compiler should not be complained about unless required
  • over 2 years Bad error message "No package matches ..."
  • over 2 years next: `opam init` fails on FreeBSD
  • over 2 years Allow to install files in /var/lib in OPAM install files
  • over 2 years opam init fails on Bash on Ubuntu on Windows
  • over 2 years opam install and opam update both fail with "Fatal error: Stack overflow"
  • over 2 years Installing package with the -t flag installs test dependencies of all dependent packages
  • over 2 years opam on windows passes Windows-style filepath to tar
  • over 2 years sh: `opam-switch-eval': not a valid identifier
  • over 2 years Usage of opam packages with third parties
  • over 2 years Depending on package features
  • over 2 years Defining two packages from the same package description
  • over 2 years Supporting dependencies on packages in specific remotes
  • over 2 years Seemingly incorrect build dependency report
  • over 2 years opam cannot install extlib
  • over 2 years conf-* packages should be installed before other packages are uninstalled
  • over 2 years Make "pin add" the default pin action
  • over 2 years opam pin add obuild git@github.com:ocaml-obuild/obuild.git
  • over 2 years svn URLs not supported in opam file in the dev-repo field
  • over 2 years git branch fetches failing in older distros
  • over 2 years Package variants: a trivial cross-compilation solution
  • over 2 years Feature request: more convenient communication with recipe
  • over 2 years Is there a way to make opam use a solver that will find a solution
  • over 2 years feature request: find latest working version of a dependency
  • over 2 years "link" kind for opam pin
  • over 2 years Add `description` field to findlib subpackages
  • over 2 years Solver don't want to choose the latest package version
  • over 2 years cudf tarball's checksum has changed
  • over 2 years Error during switch reinstall leads to broken OPAM
  • over 2 years Official PPA is badly designed
  • over 2 years Best effort `opam switch import`
  • over 2 years opam lint should be configurable
  • over 2 years Packages testing for presence of Cygwin
  • over 2 years Crash with broken installation if upgrade called from invalid cwd
  • over 2 years ocamlfind cannot find camlp5 when camlp5 is downgraded to camlp5.6.04 after ocamlfind is installed
  • over 2 years opam install apron fails
  • over 2 years opam fails to install 3.11.1 (Error: .size expression for camlRandom__rawfloat_126 does not evaluate to a constant)
  • over 2 years opam lint ignores `opam/opam` in current working directory
  • over 2 years Closed source material needs to be manually added in this similar to nix flow + depexts on nix?
  • over 2 years support for packages local to a repository
  • over 2 years .install files and executable bit
  • over 2 years can't I 'opam repo add git://some_git#some_branch'
  • over 2 years `opam-admin make --resolve` crashes
  • over 2 years opam file accepts `post-message:` field but does nothing
  • over 2 years would be nice to have a flag enforce-depext in the .opam/config file
  • over 2 years opam lint should check that URL fields look like URLs
  • over 2 years delete empty directories after removing files
  • over 2 years opam cp bug
  • over 2 years Several issues when using opam admin make by compiling from 1.2.2 sources
  • over 2 years Suggestion: renaming opam files
  • over 2 years opam lint should not warn for missing dev-repo if there is no `url`
  • over 2 years is there a way to install binaries globally
  • over 2 years SVN dev-repo support
  • over 2 years CVS dev-repo support
  • over 2 years Upgrade to dose 3.4.1?
  • over 2 years External solver failure 9 'unsafe variables', on OS X

opam closed issues

  • almost 2 years can't we have OS constraints in the depends section of an opam file ?
  • almost 2 years feature request: 'opam assume PKG' command
  • almost 2 years Make latest stable version (1.2.2) compilable
  • almost 2 years Problem when trying to install utop
  • almost 2 years variables.sh MANPATH odd?
  • almost 2 years Ocsfml installation fail
  • almost 2 years [Alpha5] Can't install any package. Bad error message about syntax error (which location is not obvious)
  • almost 2 years make -j broken
  • almost 2 years https://opam.ocaml.org/packages/, add doc field to package pages
  • almost 2 years opam init ERROR
  • almost 2 years opam2 admin: convert all compiler descriptions to new format
  • almost 2 years Trying to create a local switch (v2) wants to upgrade my global switch (v1.2.2)
  • almost 2 years Constrain package names to a reasonable set
  • almost 2 years Move OPAM's data formats to sexps
  • about 2 years `opam pin remove` vs `opam remove && opam pin remove`
  • about 2 years conf-pkg-config appears to be broken
  • about 2 years broken url for extlib in 1.2.2